[omniORB] omniNames on Solaris 2.6 with 2 IP addresses

Brendan Cully brendan@kublai.com
Tue, 11 Aug 1998 21:18:04 -0400

On Tue, Aug 11, 1998 at 12:08:02PM +0100, Sai-Lai Lo wrote:
> Brendan Cully <brendan@kublai.com> writes:
> > I just compiled and installed the april snapshot on a solaris 2.6 box.
> > The problem is, objects only seem to be able to talk to each other
> > intermittently. I compiled the echo examples and eg1 works always,
> > eg2_clt only sometimes talks to eg2_impl, and eg3_impl never succeeds,
> > although if I run nameclt (which also only sometimes works) I can see that
> > eg3_impl does sometimes manage to create the first context.
> > 
> > My machine has one ethernet card with 2 IP addresses (aliased), which I think
> > might be confusing IIOP. I built the same version of omniorb on winnt4, and
> > if I run omniNames on nt4 and use its IOR in the Solaris omniORB.cfg file,
> > eg3 works like a charm.
> > 
> > Anyone know anything about this?
> If you prefer, you can tell omniORB2 to put a specific hostname in the IOR
> instead of letting it goes and finds out the IP address of the machine,
> which as you know does not work very well on a machine with multiple
> network addresses. Just define the environment variable:
> export OMNIORB_USEHOSTNAME=wib.orl.co.uk
> Sai-Lai

Okay, I've tried using this variable. I find that when I try to bind to the
primary IP on the machine (corresponding to interface hme0) I get exactly
the same errors I got before... but when I bind to the second interface
(hme0:1), the example files generate system exceptions (as opposed to 
the intermittend COMM_FAILURE messages I was getting used to). When I get
back to work I'll dig up the exact text of the message, and see whether I
can get more details from the exception.

Is it just having two IP addresses, or can it be related to Solaris 2.6,
which I guess is not an official stable platform...

Thanks for your time,